The scheduled maintenance has been completed successfully. The service is now fully operational.
Posted Sep 21, 2026 - 15:50 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 21, 2026 - 14:45 CEST
Scheduled
Please be aware that Cosmos (ATOM) upgrade to version 28.2.0 is scheduled for September 21st, 03:15 PM CEST.
During the maintenance window, your Cosmos operations — including getting transactions, balance updates, and the send feature — may be temporarily unavailable.
We will update this notification with progress. It will be closed once the maintenance is completed and the service is fully operational.
Posted Sep 21, 2026 - 14:13 CEST
This scheduled maintenance affected: Ledger Explorers (Cosmos (ATOM)).