DOT Node API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 20:26 CEST
Investigating
DOT Node API Latency is critical.
Posted Oct 14, 2021 - 20:26 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).