"Explorer ATOM" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Dec 14, 2021 - 16:40 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Dec 14, 2021 - 16:04 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).