Binance (BNB) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 08, 2023 - 15:37 CET
Investigating
We have detected a problem with getting latest blockchain data from Binance (BNB) explorer. This is being investigated by the team.
Posted Nov 08, 2023 - 15:21 CET
This incident affected: Ledger Explorers (Binance (BNB)).