Cardano (ADA) Mainnet Service Disruption
Incident Report for
Ledger
Resolved
The incident has been resolved, please update to the latest Ledger Live version.
Posted
Oct
16
,
2024
-
18:55
CEST
Update
We are continuing to investigate this issue.
Posted
Sep
24
,
2024
-
14:22
CEST
Investigating
We are currently investigating this issue.
Posted
Sep
24
,
2024
-
14:22
CEST
This incident affected: Ledger Explorers (Cardano (ADA)).
×
Subscribe to Incident
Subscribe to updates for
Cardano (ADA) Mainnet Service Disruption
via . You'll receive .