Ledger Recover Service Disruption

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Sep 15, 2026 - 11:14 CEST

Identified

We are currently investigating an issue affecting the Ledger Recover service. Some users may be unable to access Recover at this time. Our team is actively working to restore full functionality and will share an update as soon as more information is available. We apologize for the inconvenience.
Posted Sep 15, 2026 - 11:02 CEST
This incident affected: Ledger Recover.