XST Explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 12, 2021 - 08:40 CET
Investigating
XST Explorer API test has failures detected. We are checking this incident.
Posted Feb 12, 2021 - 08:40 CET
This incident affected: Ledger Explorers (Stealthcoin (XST)).