ATOM Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 19:40 CET
Investigating
ATOM Explorer API Latency is critical.
Posted Nov 28, 2022 - 19:39 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).