PPC explorer does not have latest blockchain data

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Sep 20, 2022 - 14:06 CEST

Investigating

We have detected a problem with getting latest blockchain data from PPC explorer. We are checking this incident.
Posted Sep 20, 2022 - 14:06 CEST
This incident affected: Ledger Explorers (Peercoin (PPC)).