DOT Node API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 20:49 CET
Investigating
DOT Node API Latency is critical.
Posted Mar 24, 2021 - 20:43 CET
This incident affected: Ledger Explorers (Polkadot (DOT)).