Binance (BNB) Mainnet api is down.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 01:45 CEST
Investigating
We have detected an issue with Ledger services for blockchain Binance (BNB) Mainnet. This is being investigated by the team.
Posted Apr 02, 2024 - 01:36 CEST
This incident affected: Ledger Explorers (Binance (BNB)).