TRX Explorer API Latency is critical.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 13, 2022 - 16:52 CET

Investigating

TRX Explorer API Latency is critical.
Posted Nov 13, 2022 - 16:38 CET
This incident affected: Ledger Explorers (Tron (TRX)).