VIA Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 18, 2023 - 17:17 CET
Investigating
We have detected a problem with getting latest blockchain data from VIA Explorer. We are checking this incident.
Posted Mar 18, 2023 - 16:54 CET
This incident affected: Ledger Explorers (Viacoin (VIA)).