Tezos (XTZ) Mainnet api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 20:03 CET
Investigating
We have detected an issue with fetching the latest blockchain data from Tezos (XTZ) Mainnet. This is being investigated by the team.
Posted Mar 15, 2024 - 19:47 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).