Bitcoin (BTC) Mainnet api is down.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 16:54 CEST
Investigating
We have detected an issue with Ledger services for blockchain Bitcoin (BTC) Mainnet. This is being investigated by the team.
Posted Apr 18, 2024 - 16:47 CEST
This incident affected: Ledger Explorers (Bitcoin (BTC)).