Tezos (XTZ) explorer does not have latest blockchain data

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 03, 2023 - 11:53 CET

Investigating

We have detected a problem with getting latest blockchain data from Tezos (XTZ) explorer. This is being investigated by the team.
Posted Nov 03, 2023 - 11:52 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).