"Explorer LTC" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Aug 24, 2020 - 17:42 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Aug 24, 2020 - 17:31 CEST
This incident affected: Ledger Explorers (Litecoin (LTC)).