Blockchain Filecoin (FIL) node is down.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 12, 2023 - 02:19 CEST
Investigating
We have detected an issue with Ledger services for blockchain Filecoin (FIL). This is being investigated by the team.
Posted May 12, 2023 - 01:24 CEST
This incident affected: Ledger Explorers (Filecoin (FIL)).