Degraded ability to send and swap USDT and to swap Ethereum on Ledger Live with Ledger Nano S devices

Incident Report for Ledger

Resolved

The incident has been successfully resolved. To ensure you're using the updated version, please upgrade your Ledger Live Desktop to version 2.126.2.
Posted Sep 04, 2025 - 08:00 CEST

Investigating

We are currently experiencing technical challenges when using Ledger Live with Ledger Nano S devices. This may impact your ability to send and swap USDT and to swap Ethereum. Our team is actively working to resolve the issue.
Posted Aug 29, 2025 - 16:04 CEST
This incident affected: Swap API.