Avalanche (AVAX) C api does not have the latest blockchain data.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Feb 03, 2024 - 14:05 CET
Investigating
We have detected an issue with fetching the latest blockchain data from Avalanche (AVAX) C. This is being investigated by the team.
Posted Feb 03, 2024 - 13:53 CET
This incident affected: Ledger Explorers (Avalanche C (AVAX)).