SOL Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 17:45 CET
Investigating
We have detected a problem with getting latest blockchain data from SOL Explorer. We are checking this incident.
Posted Mar 20, 2023 - 17:43 CET
This incident affected: Ledger Explorers (Solana (SOL)).