NEAR Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 27, 2023 - 21:19 CEST
Investigating
We have detected a problem with getting latest blockchain data from NEAR Explorer. We are checking this incident.
Posted Mar 27, 2023 - 21:12 CEST
This incident affected: Ledger Explorers (Near Protocol (NEAR)).