Multiple Ledger Wallet services experiencing intermittent errors

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Aug 19, 2026 - 19:20 CEST

Monitoring

All affected services are working again. We are continuing to closely monitor stability before considering this incident closed.
Posted Aug 19, 2026 - 19:13 CEST

Investigating

Some users may currently experience intermittent errors, slow loading, or failed requests across several Ledger Wallet features, including Buy, Swap, Earn, and Card top-up. Our teams have identified the affected infrastructure and are actively working to restore full service. We apologize for the inconvenience and will post updates here as we have them.
Posted Aug 19, 2026 - 19:01 CEST
This incident affected: Buy, Earn Dashboard, Countervalue API, Swap API, Trustchain, Ledger Quest, and Card Program.