"Explorer SOL" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jun 10, 2022 - 11:41 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Jun 09, 2022 - 22:38 CEST
This incident affected: Ledger Explorers (Solana (SOL)).