"Explorer DGB" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 13:06 CET
Investigating
Error code HTTP 503 - Service Unavailable
Posted Mar 18, 2021 - 12:39 CET
This incident affected: Ledger Explorers (DigiByte (DGB)).