Cosmos (ATOM) Mainnet api 5xx response rate.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 15:12 CET
Investigating
We have detected an issue with Ledger services for blockchain Cosmos (ATOM) Mainnet. This is being investigated by the team.
Posted Mar 20, 2024 - 12:36 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).