VTC Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 14:15 CEST
Investigating
We have detected a problem with getting latest blockchain data from VTC Explorer. We are checking this incident.
Posted Sep 20, 2022 - 14:13 CEST
This incident affected: Ledger Explorers (Vertcoin (VTC)).