Service Loyalty Program is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Jul 31, 2024 - 08:00 CEST

Investigating

We have detected an issue with service Loyalty Program. This is being investigated by the team.
Posted Jul 31, 2024 - 07:58 CEST
This incident affected: Loyalty Program.