XST Explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 14:09 CEST
Investigating
XST Explorer API test has failures detected. We are checking this incident.
Posted Apr 02, 2021 - 14:07 CEST
This incident affected: Ledger Explorers (Stealthcoin (XST)).