Polygon (MATIC) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 12:31 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 13, 2023 - 12:29 CEST
Investigating
We have detected a problem with getting latest blockchain data from Polygon (MATIC) explorer. This is being investigated by the team.
Posted Sep 13, 2023 - 11:22 CEST
This incident affected: Ledger Explorers (Polygon (MATIC)).