Blockchain Cosmos (ATOM) explorer eu is down.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 15:23 CEST
Investigating
We have detected an issue with Ledger services for blockchain Cosmos (ATOM). This is being investigated by the team.
Posted Sep 13, 2023 - 15:13 CEST
This incident affected: Ledger Explorers (Cosmos (ATOM)).