XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 15, 2021 - 21:16 CEST
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted May 15, 2021 - 20:41 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).