Vertcoin (VTC) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 24, 2023 - 22:18 CEST
Investigating
We have detected a problem with getting latest blockchain data from Vertcoin (VTC) explorer. This is being investigated by the team.
Posted May 24, 2023 - 20:41 CEST
This incident affected: Ledger Explorers (Vertcoin (VTC)).