XTZ explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jan 14, 2022 - 20:04 CET
Investigating
XTZ explorer API test has failures detected. We are checking this incident.
Posted Jan 14, 2022 - 19:38 CET
This incident affected: Ledger Explorers (Tezos (XTZ)).