Komodo (KMD) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 25, 2023 - 13:30 CEST
Investigating
We have detected a problem with getting latest blockchain data from Komodo (KMD) explorer. This is being investigated by the team.
Posted May 25, 2023 - 13:10 CEST
This incident affected: Ledger Explorers (Komodo (KMD)).