"Explorer SOL" is down
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 18:10 CEST
Investigating
Error code HTTP 503 - Service Unavailable
Posted Sep 13, 2022 - 16:21 CEST
This incident affected: Ledger Explorers (Solana (SOL)).