Algorand (ALGO) explorer does not have latest blockchain data

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 02, 2023 - 11:01 CET

Investigating

We have detected a problem with getting latest blockchain data from Algorand (ALGO) explorer. This is being investigated by the team.
Posted Nov 02, 2023 - 10:52 CET
This incident affected: Ledger Explorers (Algorand (ALGO)).