ETC explorer API has elevated error rates.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Jul 06, 2021 - 14:59 CEST
Investigating
ETC explorer API test has failures detected. We are checking this incident.
Posted Jul 06, 2021 - 14:53 CEST
This incident affected: Ledger Explorers (Ethereum Classic (ETC)).