Ledger Live Manager connection issue
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 18:20 CEST
Investigating
The Ledger Live Manager is temporarily down, our team is currently working on fixing the issue. Rest assured this doesn't affect your assets.
Posted Sep 30, 2021 - 16:51 CEST