Service Buy is down.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 00:28 CEST

Investigating

We have detected an issue with service Buy. This is being investigated by the team.
Posted Jun 17, 2025 - 00:28 CEST
This incident affected: Buy.