TRX Explorer API Latency is critical.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 10, 2022 - 01:11 CET

Investigating

TRX Explorer API Latency is critical.
Posted Nov 09, 2022 - 19:48 CET
This incident affected: Ledger Explorers (Tron (TRX)).