Issues with Tezos explorer
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Sep 26, 2022 - 17:24 CEST
Investigating
We have detected a problem with getting the latest blockchain data from XTZ node. We are working on the resolution of this case.
Posted Sep 26, 2022 - 09:44 CEST
This incident affected: Ledger Explorers (Tezos (XTZ)).