DOT Node API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 22:25 CEST
Investigating
DOT Node API Latency is critical.
Posted Oct 15, 2021 - 22:24 CEST
This incident affected: Ledger Explorers (Polkadot (DOT)).