XST Explorer API Latency is critical.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 00:21 CET
Investigating
XST Explorer API Latency is critical.
Posted Nov 19, 2020 - 00:20 CET
This incident affected: Ledger Explorers (Stealthcoin (XST)).