Decred (DCR) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 25, 2023 - 12:36 CEST
Investigating
We have detected a problem with getting latest blockchain data from Decred (DCR) explorer. This is being investigated by the team.
Posted May 25, 2023 - 12:34 CEST
This incident affected: Ledger Explorers (Decred (DCR)).