"Explorer LTC" is down

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Nov 19, 2020 - 14:00 CET

Investigating

Error code HTTP 503 - Service Unavailable
Posted Nov 19, 2020 - 13:59 CET
This incident affected: Ledger Explorers (Litecoin (LTC)).