FIL Explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 12:45 CET
Investigating
We have detected a problem with getting latest blockchain data from FIL Explorer. We are checking this incident.
Posted Mar 24, 2023 - 12:37 CET
This incident affected: Ledger Explorers (Filecoin (FIL)).