Blockchain Bitcoin Testnet (BTC Testnet) explorer is down.
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted May 24, 2023 - 22:16 CEST
Investigating
We have detected an issue with Ledger services for blockchain Bitcoin Testnet (BTC Testnet). This is being investigated by the team.
Posted May 24, 2023 - 21:14 CEST