Cosmos (ATOM) Mainnet api 5xx response rate.

Incident Report for Ledger

Resolved

This incident has been resolved.
Posted Feb 02, 2024 - 21:27 CET

Investigating

We have detected an issue with Ledger services for blockchain Cosmos (ATOM) Mainnet. This is being investigated by the team.
Posted Feb 02, 2024 - 21:26 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).