Cosmos (ATOM) explorer does not have latest blockchain data
Incident Report for Ledger
Resolved
This incident has been resolved.
Posted Oct 31, 2023 - 07:13 CET
Investigating
We have detected a problem with getting latest blockchain data from Cosmos (ATOM) explorer. This is being investigated by the team.
Posted Oct 31, 2023 - 07:09 CET
This incident affected: Ledger Explorers (Cosmos (ATOM)).